Hm... seems like you're using IE. Can I suggest a better browser, such as Firefox, Chrome or Opera? There are other choices too.

If you wanna stick with IE, or can't switch, I'll warn you right now, while most of this site should work with IE, stuff might come up buggy, so you might not enjoy it as much...

Missing Characters Tab

Oct 14, 2019 6:54 am
I've raised this on Discord where other people have commented but I have had this for a few days now, where the character tab at the top of the page is missing, when logged in. I've also noticed the Login is highlighted, even after I logged in.

Using Chrome and Windows 10 PC. I don't have the same problem on Mobile.
Oct 14, 2019 8:20 am
This same thing happens to me when I log in at work, but never at home or when on another network. I always assumed it was a firewall oddity.
Oct 14, 2019 10:23 am
Have you tried refreshing your browser cache? For Chrome it's either hold Ctrl and click the Reload button or hold down Ctrl and press F5.
Oct 16, 2019 2:33 pm
Tried that. It brings back the character tab momentarily and allows me to see the character list, but that login button still appears as if I'm not logged in. If I click on a character avatar, the character is blank. The same happens if I use the characters button at the bottom of the thread.
Oct 16, 2019 3:42 pm
I had this problem when I upgraded computers at work. Chrome wouldn't keep me logged in to various sites. There's a setting in Chrome that needs to be set right to keep you logged in. Try this.
Oct 16, 2019 6:56 pm
My settings were already set to what this advises. Chrome isn't actually logging me out. I can still see all my games and access them (which I can't do when I log out)
Oct 16, 2019 7:02 pm
It must be your personal magnetic field, then!
Oct 17, 2019 12:34 am
Haha, probably
Oct 17, 2019 3:56 am
I'll try to look into this, and steps that you may be able to run to help me debug.
Oct 17, 2019 7:15 am
This is what it looks like (logged in) on a normal thread

https://i.imgur.com/jznYEd3.jpg
Oct 17, 2019 7:18 am
If I hit ctrl F5 I get this (the previously normal state)

https://i.imgur.com/vsYcRr5.jpg
Oct 17, 2019 7:19 am
But as soon as I post (as I just did) it reverts back to the previous image, with no character tab.
Oct 17, 2019 7:23 am
If I hit the character tab, it hangs like this:
https://i.imgur.com/aRBOTkW.jpg
Oct 17, 2019 7:33 am
Knifesedgegames says:
If I hit the character tab, it hangs like this:
That happens to me as well from time to time but if I exit and try again it works for me
Oct 17, 2019 8:07 am
It only happens on one PC as well. My laptop, with the same setup - Chrome and Win10 has no problem at all.
Oct 17, 2019 7:36 pm
Ok, so there's some bug that seems to not recognize you as logged in. I suspect it has to do with some data reaching your system later than it should. I'll think about how I can address that in the short term.
Oct 23, 2019 12:28 pm
Incidentally, I just tried to use GP on Microsoft Edge browser and the same thing happens.
Oct 23, 2019 4:48 pm
In chrome, press F12, that'll bring up the devTools.
Click the network tab in the devTools.
Try navigating.
Do you get errors in the Console window or Network tab?
Does "getHeader/" appear in the Network tab?

@devs - below are a few tag mismatches I noticed. I'm sure none of these are the error (the browser should work around these), but it can't hurt to fix them. The code looks odd because I've replaced less-than, greater-than with parentheses just so this'll post here.


characters/my.php: line 63
(h2 class="headerbar hbDark")New Character(/h1)
Close h2, not h1

includes/forums/ForumSearch.class.php: line 124
(div class="byLine")by (a href="/user/(?=$result-)lp_authorID?)/" class="username")(?=$result-)lp_username?)(/a), (span class="convertTZ")(?=date('M j, Y g:i a', strtotime($result-)lp_datePosted))?)(/div)
Close the .convertTZ span

games/details.php: line 64
(div)(span ng-repeat="system in details.allowedCharSheets")(span ng-bind-html="systems[system] | trustHTML")(/span)(span ng-if="!$last"), (/span)(/div)
Three open spans, two closed
Last edited October 23, 2019 4:48 pm, a total of 1 time
Oct 23, 2019 4:59 pm
I've no idea if I did this correctly, but there seems to be one error, this appears in the console

TypeError: ns.GetCommandSrc is not a function
at GetCommandUrl (main.js:988)
at XMLHttpRequest.window.XMLHttpRequest.open (main.js:1023)
at angular.min.js?v=1.5.8:102
at n (angular.min.js?v=1.5.8:99)
at angular.min.js?v=1.5.8:96
at angular.min.js?v=1.5.8:131
at m.$eval (angular.min.js?v=1.5.8:145)
at m.$digest (angular.min.js?v=1.5.8:142)
at m.$apply (angular.min.js?v=1.5.8:146)
at angular.min.js?v=1.5.8:20
(anonymous) @ angular.min.js?v=1.5.8:118
(anonymous) @ angular.min.js?v=1.5.8:90
(anonymous) @ angular.min.js?v=1.5.8:131
$eval @ angular.min.js?v=1.5.8:145
$digest @ angular.min.js?v=1.5.8:142
$apply @ angular.min.js?v=1.5.8:146
(anonymous) @ angular.min.js?v=1.5.8:20
invoke @ angular.min.js?v=1.5.8:41
c @ angular.min.js?v=1.5.8:20
Bc @ angular.min.js?v=1.5.8:21
fe @ angular.min.js?v=1.5.8:20
(anonymous) @ angular.min.js?v=1.5.8:317
c @ jquery.min.js?v=1.0.0:4
fireWith @ jquery.min.js?v=1.0.0:4
ready @ jquery.min.js?v=1.0.0:4
q @ jquery.min.js?v=1.0.0:4
Oct 23, 2019 5:42 pm
That's helpful. Are you running Kaspersky Internet Security or similar?
1 of 2
1 2 >

You do not have permission to post in this thread.